Der JoomFish 2.0 Release und seine PHP 4 Kompatibilität

Der JoomFish 2.0 Release und seine PHP 4 Kompatibilität

Übersetzung des original Artikels auf joomfish.net:

Nun geht es nur noch ein Tag bis zur Veröffentlichung der JoomFish Version 2.0 RC. Wir hoffen, dass die Community keine grösseren Fehler mehr finden wird.

Es ist schön zu sehen, dass die Liste der Übersetzungen der Joomfish Komponente laufend am Wachsen ist.

Bisher können wir 16 verschiedene Übersetzungen in unseren Downloads anbieten. Sollten Sie Ihre Sprache nicht in den Downloads finden und sehen Sie in unserem Forum keinen Eintrag, dass die Sprache in Vorbereitung ist, können Sie uns schreiben, wenn Sie gerne eine Übersetzung vorbereiten möchten.

Was aber noch viel wichtiger ist, ist die Ankündigung, ob JoomFisch mit PHP 4 funktioniert. Die neue Version 2.0 wurde auf einer PHP 5.0 Umgebung entwickelt und getestet. Aber wir haben versucht, den Code auch auf PHP 4.0 rückwärtskompatibel zu machen. Der Code sollte also noch mit PHP 4.0 funktionieren. Als Benutzer sollten Sie aber wissen, dass der Support von PHP 4.0 Umgebungen per August 2008 eingestellt wurde (hier nachzulesen). Daher können wir nur noch PHP 5.0 Installationen supporten.

Die nächste JoomFish 2.1 Version wird dann nur noch für PHP 5.0 geschrieben sein.

Falls Ihr Hosting Provider noch PHP 4.0 im Einsatz haben sollte, fragen Sie ihn, wann er das Update auf die aktuelle PHP-Version plant. Es gibt im Internet verschiedene Diskussionen zum Thema, warum man die PHP 4.0 Version lieber in Frieden ruhen lassen sollte. Wir werden dies an dieser Stelle nicht nochmal begründen. Kurz gesagt wird Ihre Seite mit der neuen PHP-Version viel schneller und sicherer sein als mit der früheren PHP-Version.