Joomla 3.1.4 Probleme mit Drittanbieter Erweiterungen

Joomla 3.1.4 Probleme mit Drittanbieter Erweiterungen

Die gestern erschienene Joomla 3.1.4 Version scheint mit verschiedenen Drittanbietern-Erweiterungen (3pd-Extensions) Probleme zu machen.

Beim Aufruf der Komponente kann ein Error 500 hervor gerufen werden. Es wird mit Hochdruck an einem Patch gearbeitet.

D.h. es wird in wenigen Tagen die Version 3.1.5 erscheinen. Für die, welche nicht solange warten können oder wollen gibt es jetzt schon einen provisorischen Patch, den man via den Erweiterungen-Manager im Backend installieren kann. Der Download findet ihr am Ende des Artikels.

Der Patch installiert die alte legacy.php aus der Version 3.1.1. Installiert ihn nur, wenn ihr wirklich einen Error 500 beim Aufruf einer Fremd-Komponente in Joomla! 3.1.4 habt. Der Joomla! Core ist davon nicht betroffen.

Das Problem tritt beim Aufruf der sog. “carmel class” in den “views” einer Erweiterung auf. Alle Erweiterungen (z.B. K2Store, EasyBook reloaded, Phoca Gallery usw.), welche diese Klasse verwenden, erzeugen im Moment mit der Version 3.1.4 einen Error 500. Konkret ist die Datei: libraries/legacy/view/legacy.php betroffen.

Alle Joomla!-Eigenen Erweiterungen funktionieren normal und ohne Probleme.

Quelle: docs.joomla.org

Download Joomla Legacy Hotfix